Issue w/ upstream provider leading to degraded performance
Incident Report for AutoReach
Resolved
This incident has been resolved.
Posted Aug 15, 2022 - 17:41 PDT
Investigating
We are currently investigating this issue.
Posted Aug 15, 2022 - 15:42 PDT
This incident affected: Campaign Management, API, and CSV Dialer.